Bitcoin Forum
December 11, 2018, 06:41:02 PM *
News: Latest Bitcoin Core release: 0.17.0 [Torrent].
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: 64: too-long-mempool-chain  (Read 86 times)
tsubasa1380
Newbie
*
Offline Offline

Activity: 15
Merit: 2


View Profile
May 14, 2018, 06:30:34 AM
 #1

I'm running full node bitcoin server and use bitcoin-core RPC library.

I sent transaction by using rpc command 'sendrawtransaction'
but the result returned err as below.

64: too-long-mempool-chain

So I checked memopool by using rpc command 'getmempoolinfo', then returned as follows.
{
  "size": 0,
  "bytes": 0,
  "usage": 96,
  "maxmempool": 300000000,
  "mempoolminfee": 0.00000000
}

What should I do for sending transaction successfully ?

Additinal information.
I use Bitcoin Core : version 0.13
1544553662
Hero Member
*
Offline Offline

Posts: 1544553662

View Profile Personal Message (Offline)

Ignore
1544553662
Reply with quote  #2

1544553662
Report to moderator
1544553662
Hero Member
*
Offline Offline

Posts: 1544553662

View Profile Personal Message (Offline)

Ignore
1544553662
Reply with quote  #2

1544553662
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1544553662
Hero Member
*
Offline Offline

Posts: 1544553662

View Profile Personal Message (Offline)

Ignore
1544553662
Reply with quote  #2

1544553662
Report to moderator
1544553662
Hero Member
*
Offline Offline

Posts: 1544553662

View Profile Personal Message (Offline)

Ignore
1544553662
Reply with quote  #2

1544553662
Report to moderator
1544553662
Hero Member
*
Offline Offline

Posts: 1544553662

View Profile Personal Message (Offline)

Ignore
1544553662
Reply with quote  #2

1544553662
Report to moderator
HCP
Hero Member
*****
Offline Offline

Activity: 812
Merit: 989

<insert witty quote here>


View Profile
May 14, 2018, 11:03:32 AM
Merited by achow101 (2)
 #2

I believe that means there are too many "unconfirmed" parent transactions... You can try using the suggestion here: http://bitcoin.stackexchange.com/questions/59178/64-too-long-mempool-chain

By using the -limitancestorcount and/or -limitdescedantcount commandline arguments, you can override the default limit of 25 unconfirmed transactions.

tsubasa1380
Newbie
*
Offline Offline

Activity: 15
Merit: 2


View Profile
May 15, 2018, 02:44:23 AM
 #3

I believe that means there are too many "unconfirmed" parent transactions... You can try using the suggestion here: http://bitcoin.stackexchange.com/questions/59178/64-too-long-mempool-chain

By using the -limitancestorcount and/or -limitdescedantcount commandline arguments, you can override the default limit of 25 unconfirmed transactions.
Thank you for your answer.

Surely you are right.
There are too many "unconfirmed" parent transactions.

Can I override the default limit of 25 unconfirmed transactions by adding to cofiguration file as below.

  1.  Additionally write to configuration file.
  bitcoin.conf-----------------------
  limitancestorcount=1000 ← e.g. 1000
  limitdescedantcount=1000 ← e.g. 1000
  ----------------------------------
  2. Restart bitcoind with -reindex options.

Then try to sendrawtransaction again.

How about this ?
achow101
Moderator
Legendary
*
expert
Offline Offline

Activity: 1610
Merit: 1789


bc1qshxkrpe4arppq89fpzm6c0tpdvx5cfkve2c8kl


View Profile WWW
May 15, 2018, 04:20:08 AM
 #4

Can I override the default limit of 25 unconfirmed transactions by adding to cofiguration file as below.

  1.  Additionally write to configuration file.
  bitcoin.conf-----------------------
  limitancestorcount=1000 ← e.g. 1000
  limitdescedantcount=1000 ← e.g. 1000
  ----------------------------------
Sure, you can do that, but that does not mean that your transactions will actually be relayed across the network. Just because you have this in your config does not mean that your peers will so they likely won't accept any transactions once you reach the default limit. Your local config only applies to your node. Changing this just means the transactions will sit in your node's mempool (and not be relayed across the network). They won't even be rebroadcast by your node because nodes don't do that.

Instead of trying to get long unconfirmed transaction chains to be relayed, you should be rethinking why you are generating long unconfirmed transaction chains and thinking of ways that you can avoid making long unconfirmed transaction chains instead.

 2. Restart bitcoind with -reindex options.
No need to do that. This has nothing to do with the databases.

tsubasa1380
Newbie
*
Offline Offline

Activity: 15
Merit: 2


View Profile
May 15, 2018, 05:02:50 AM
 #5

Sure, you can do that, but that does not mean that your transactions will actually be relayed across the network. Just because you have this in your config does not mean that your peers will so they likely won't accept any transactions once you reach the default limit. Your local config only applies to your node. Changing this just means the transactions will sit in your node's mempool (and not be relayed across the network). They won't even be rebroadcast by your node because nodes don't do that.
Tank you for the explanation. I understand.
If I override the default limit , this applies only to my node.

Instead of trying to get long unconfirmed transaction chains to be relayed, you should be rethinking why you are generating long unconfirmed transaction chains and thinking of ways that you can avoid making long unconfirmed transaction chains instead.
Thank you for your advice. I will try to improve it.

No need to do that. This has nothing to do with the databases.
Does this  means that there is no need for adding reindex options ?
  2. Restart bitcoind (← without adding -reindex options)
achow101
Moderator
Legendary
*
expert
Offline Offline

Activity: 1610
Merit: 1789


bc1qshxkrpe4arppq89fpzm6c0tpdvx5cfkve2c8kl


View Profile WWW
May 15, 2018, 05:09:18 AM
 #6

No need to do that. This has nothing to do with the databases.
Does this  means that there is no need for adding reindex options ?
  2. Restart bitcoind (← without adding -reindex options)
Correct. Just restart without -reindex

tsubasa1380
Newbie
*
Offline Offline

Activity: 15
Merit: 2


View Profile
May 15, 2018, 05:17:54 AM
 #7

Correct. Just restart without -reindex

Than you for your replay!

I will restart bitcoind without -reindex, and then try to sendrawtransaction agan.


Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!